12V power port not working...

LiquidSpin

New member
4
0
1
Genesis Model Type
1G Genesis Coupe (2009-2016)
Hey all, I'm new to the forum and having issues with one of my 12v power ports:

Details:
2011 Hyundai Genesis Coupe 2.0T Premium
front 12V power adapter works
Arm rest USB port works
Checked the fuse and it's fine and not blown

It's just the rear 12v power adapter that all of a sudden stopped working after about a month.

Original power adapter was ruined when a charger I plugged in somehow started to melt inside. The plastic covered the bottom metal connector base and there was no way of scrapping it off so I tossed it and bought a new one.

I bought an authentic Hyundai part but it had a slightly different part number and was made for the Sonata I believe. Part #95120 - 3K500.

I don't think this would be an issue but is it? Or could it be something else? Any suggestions?
 

16UltV6Guy

Bill the Cat for President
SUSTAINING MEMBER
345
185
43
Jax, FL
Genesis Model Type
2G Genesis Sedan (2015-2016)
Wouldn't think that the power adapter would make any difference.

Is there 12v power at the wires/connector at the rear power adapter location? Does the key need to be on for the rear power adapter to work, or is it always powered on?
 

G-749464

Wouldn't think that the power adapter would make any difference.

Is there 12v power at the wires/connector at the rear power adapter location? Does the key need to be on for the rear power adapter to work, or is it always powered on?

I use the rear power adapter for my dashcam and when I cut off the engine the dashcam shuts off due to no power. So it's definitely not on all the time. I would assume that would slowly drain the battery potentially.

I don't have a multi meter to test the wire connectors unfortunately. :(
 

LiquidSpin

New member
4
0
1
Genesis Model Type
1G Genesis Coupe (2009-2016)
So i use the rear power adapter for my dashcam. When I shut off the engine the dashcam turns off. Meaning it's getting no power so it definitely doesn't stay on all the time.

I really thought I blew the fuse but when I inspected the fuse it wasn't burned out and the metal inside is perfectly intact. This is driving me nuts :(
______________________________
 

joegr

Registered Member
385
158
43
Genesis Model Year
2018
Genesis Model Type
Genesis G80
...I really thought I blew the fuse but when I inspected the fuse it wasn't burned out and the metal inside is perfectly intact. This is driving me nuts :(

You really can't always tell just by looking. A cheap ($10) DMM would likely lead you straight to the problem. It would answer with certainty if the fuse is open or not, and it you are getting 12V at the power port while the car is in accessory or run.
 

16UltV6Guy

Bill the Cat for President
SUSTAINING MEMBER
345
185
43
Jax, FL
Genesis Model Type
2G Genesis Sedan (2015-2016)
You need to verify that you actually have 12v power back there at the connector/wires. There might be a break in the circuit somewhere.
 

LiquidSpin

New member
4
0
1
Genesis Model Type
1G Genesis Coupe (2009-2016)
Thanks guys, I just ordered a $7 + $7 shipping (yuck) Digital Multi-meter. I would have just gone to the store and picked one up but I live in VA and they have now done an executive order to stay at home just like NYC. Hopefully, it's just a bad fuse...those are cheap and easy to replace. *fingers crossed*
 

16UltV6Guy

Bill the Cat for President
SUSTAINING MEMBER
345
185
43
Jax, FL
Genesis Model Type
2G Genesis Sedan (2015-2016)
In the mean time, do you have a spare fuse you could pop in there to rule out it being a fuse issue?
______________________________
 

G-327843

Hey all, I'm new to the forum and having issues with one of my 12v power ports:

Details:
2011 Hyundai Genesis Coupe 2.0T Premium
front 12V power adapter works
Arm rest USB port works
Checked the fuse and it's fine and not blown

It's just the rear 12v power adapter that all of a sudden stopped working after about a month.

Original power adapter was ruined when a charger I plugged in somehow started to melt inside. The plastic covered the bottom metal connector base and there was no way of scrapping it off so I tossed it and bought a new one.

I bought an authentic Hyundai part but it had a slightly different part number and was made for the Sonata I believe. Part #95120 - 3K500.

I don't think this would be an issue but is it? Or could it be something else? Any suggestions?
Where is the 12V adapter in the FRONT of the car ? I have not found it yet ... Also, my REAR 12V adapter seemed to work inconsistently when I tried to plug in a low wattage tire inflator . Probaly need to havethe dealer resolve that .
Thanks
 
The Genesis License Plate Frame
Tired of waiting for a Genesis SUV?
hyundai palisade forums
Top