2012 5.0 Sedan Transmission Issues

SixFootSix

Registered Member
82
1
8
California
For the past month my 8-speed transmission has had a bit of a shifting issues that comes and goes. The issue is that when shifting from 2nd to 3rd under medium acceleration the rpms will jump from 1400 to over 2200+ and then slams into 3rd gear. After several rests with motor off the problem goes away.

A friend suggested that it could be a temperature issue but the problem has existed even when the car has sat for several hours.

Shifts from 4 to 5 and upwards are working crisper, but not as violent as 2nd to 3rd.

2012 Genesis 5.0 Sedan
Stock
88,000 miles
 

Hero6

Hasn't posted much yet...
29
1
3
Florida
Genesis Model Type
1G Genesis Sedan (2009-2014)
SixFootSix,
Just my experience...I have a 2011 4.6 and had a similar issue at around 95,000, although mine has the 6 speed ZF as opposed to yours. Mine would "slip" around 25-30 miles an hour, and sometimes slam into gear. As with yours, mine also did not do it all the time, but got progressively worse as time went on. Took it to Hampton Hyundai in Ft Walton FL, they tried to reset the transmission to "re-learn", but ended up having to replace the transmission. I had an "Easy Care " aftermarket warranty, and they paid for a used transmission (55,000 miles on it) to be installed by the dealer. Do you have a warranty?
 

carguy75

Registered Member
615
209
43
Atlanta, Georgia
Genesis Model Type
2G Genesis Sedan (2015-2016)
For the past month my 8-speed transmission has had a bit of a shifting issues that comes and goes. The issue is that when shifting from 2nd to 3rd under medium acceleration the rpms will jump from 1400 to over 2200+ and then slams into 3rd gear. After several rests with motor off the problem goes away.

A friend suggested that it could be a temperature issue but the problem has existed even when the car has sat for several hours.

Shifts from 4 to 5 and upwards are working crisper, but not as violent as 2nd to 3rd.

2012 Genesis 5.0 Sedan
Stock
88,000 miles
I would first change the old 7yeay old transmission fluid/filter and see if the shifting improves. If not, then I would be concerned about the valve body and shift solenoids.
 

SixFootSix

Registered Member
82
1
8
California
SixFootSix,
Just my experience...I have a 2011 4.6 and had a similar issue at around 95,000, although mine has the 6 speed ZF as opposed to yours. Mine would "slip" around 25-30 miles an hour, and sometimes slam into gear. As with yours, mine also did not do it all the time, but got progressively worse as time went on. Took it to Hampton Hyundai in Ft Walton FL, they tried to reset the transmission to "re-learn", but ended up having to replace the transmission. I had an "Easy Care " aftermarket warranty, and they paid for a used transmission (55,000 miles on it) to be installed by the dealer. Do you have a warranty?
No warranty.
______________________________
 

ThunderChicken

Registered Member
65
9
8
USA
Genesis Model Type
1G Genesis Sedan (2009-2014)
For the past month my 8-speed transmission has had a bit of a shifting issues that comes and goes. The issue is that when shifting from 2nd to 3rd under medium acceleration the rpms will jump from 1400 to over 2200+ and then slams into 3rd gear. After several rests with motor off the problem goes away.

A friend suggested that it could be a temperature issue but the problem has existed even when the car has sat for several hours.

Shifts from 4 to 5 and upwards are working crisper, but not as violent as 2nd to 3rd.

2012 Genesis 5.0 Sedan
Stock
88,000 miles
The shift harness will smooth with a fluid change but will not go away completely.

Same problem with mine.

It's a helluva car so I've learned to live with mine and yearly transmission drain/refills.

Search the forum and you'll find many a thread stating the same issue you're having, no long term permanent solution has been found but I suspect the issue is the shift points set in the TCM by Hyundai to get better fuel economy.
 

Paul

Hasn't posted much yet...
SUSTAINING MEMBER
129
30
28
Jacksonville, Fl.
Genesis Model Type
1G Genesis Sedan (2009-2014)
This is a well known issue with the very early 2012 8 speeds. Late 2011/early 2012 build dates) It seems like it was remedied as the model year progressed. @SixFootSix ; out of curiosity, when was your car manufactured? You can tell by looking at the sticker on the drivers side door jamb.
My 2012 which had a November 2011 build date started to have the same symptoms right at 99k and change. (just short of the 100k power train warranty end) but go figure, would NEVER duplicate when brought to the dealership for diagnosis. Needless to say, I just dealt with it until around 114k when I traded it on my Charger.

I was getting the hard 2~3 upshift as well as a 4~5 hard shift. It would act up for a few hours then after being parked for a while would behave for a few weeks without incident. There was no pattern such as weather, temp or humidity or how I was driving the car. (Babying it or beating it. I had the trans flushed/filled and a TCM reflash at the dealership as part of their recommended diagnosis, but again, it never acted up when they had it. They refused to take action, even after showing them a video while it was acting up.

Since your car has no warranty, perhaps take it to a reputable transmission shop and see if they have any suggestions.

It's really a shame that Hyundai got away from the ZF trans, It's really a great unit My Charger has an 8 speed ZF and it's amazing.
Hope that you can find a resolution with your car. Good luck
 

SixFootSix

Registered Member
82
1
8
California
This is a well known issue with the very early 2012 8 speeds. Late 2011/early 2012 build dates) It seems like it was remedied as the model year progressed. @SixFootSix ; out of curiosity, when was your car manufactured? You can tell by looking at the sticker on the drivers side door jamb.
My 2012 which had a November 2011 build date started to have the same symptoms right at 99k and change. (just short of the 100k power train warranty end) but go figure, would NEVER duplicate when brought to the dealership for diagnosis. Needless to say, I just dealt with it until around 114k when I traded it on my Charger.

I was getting the hard 2~3 upshift as well as a 4~5 hard shift. It would act up for a few hours then after being parked for a while would behave for a few weeks without incident. There was no pattern such as weather, temp or humidity or how I was driving the car. (Babying it or beating it. I had the trans flushed/filled and a TCM reflash at the dealership as part of their recommended diagnosis, but again, it never acted up when they had it. They refused to take action, even after showing them a video while it was acting up.

Since your car has no warranty, perhaps take it to a reputable transmission shop and see if they have any suggestions.

It's really a shame that Hyundai got away from the ZF trans, It's really a great unit My Charger has an 8 speed ZF and it's amazing.
Hope that you can find a resolution with your car. Good luck
My Genisys 5.0 was built in April 2012.
 

OUsig

Been here awhile...
234
28
28
McKinney TX
Genesis Model Type
1G Genesis Sedan (2009-2014)
do a DRAIN and FILL at a Hyundai dealership. Should cost you $200-$250 total
mine was shifting fine before I did it (around 90kmiles give or take) but it was MUCH better after and still is. at 106k miles now
______________________________
 

Hargarbl

Hasn't posted much yet...
13
4
3
FL
I have also had the same issue on and off, and same as others couldn't get it to replicate for the dealer. I went to get a drain and fill and was told it wasn't usually done (and didn't need to be done) because our transmissions are sealed. Well my "sealed" transmission sprung a super bad leak on my way home from work today after passing someone. Was smoking and the underside of my car is now wet. I'm going to try and go in this week and see what they say. But I wish you the best in getting it taken car of.
 

OUsig

Been here awhile...
234
28
28
McKinney TX
Genesis Model Type
1G Genesis Sedan (2009-2014)
I have also had the same issue on and off, and same as others couldn't get it to replicate for the dealer. I went to get a drain and fill and was told it wasn't usually done (and didn't need to be done) because our transmissions are sealed. Well my "sealed" transmission sprung a super bad leak on my way home from work today after passing someone. Was smoking and the underside of my car is now wet. I'm going to try and go in this week and see what they say. But I wish you the best in getting it taken car of.
Where did you go when you asked about getting the drain and fill done for the transmission? and yes the sealed comment is correct
oh wait it seems you went to a Hyundai dealer??? if so depending on the miles, yes they may be nonchalant when/if recommending the fluid drain and fill.
I simply told my service person at my dealer I wanted it done regardless of what the book said. He agreed as no transmission is really "service free".
 

Hargarbl

Hasn't posted much yet...
13
4
3
FL
Where did you go when you asked about getting the drain and fill done for the transmission? and yes the sealed comment is correct
oh wait it seems you went to a Hyundai dealer??? if so depending on the miles, yes they may be nonchalant when/if recommending the fluid drain and fill.
I simply told my service person at my dealer I wanted it done regardless of what the book said. He agreed as no transmission is really "service free".
Yeah it was the dealer and I had roughly 105k miles on it. The service manager is the person who told me this.
 

OUsig

Been here awhile...
234
28
28
McKinney TX
Genesis Model Type
1G Genesis Sedan (2009-2014)
Honestly if you had not touched the fluid in 105k miles...not sure if a drain/fill would have helped much. But it certainly would not hurt - unlike a transmission flush (big no no no no no).
please update when you find out what the problem is/why the fluid is leaking. I cannot understand why that would happen regardless if you have replaced the fluid 10 times or never.

good luck and again, please update this thread
______________________________
 

Hargarbl

Hasn't posted much yet...
13
4
3
FL
Honestly if you had not touched the fluid in 105k miles...not sure if a drain/fill would have helped much. But it certainly would not hurt - unlike a transmission flush (big no no no no no).
please update when you find out what the problem is/why the fluid is leaking. I cannot understand why that would happen regardless if you have replaced the fluid 10 times or never.

good luck and again, please update this thread
I purchased the car with roughly 70k miles on it and I'm assuming it wasn't done at that point. I will be sure to update. As of now she is driving fine so I have a bit of time to find a day to be able to get her in. No more leaking either that I have noticed, well no heavy leaking anyway, I'm sure its still leaking a tiny bit. Hopefully not too long though. And now I'm wondering if the dealer thought I was asking for a flush, which still makes me wonder why they wouldn't have just recommended the drain and fill instead.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top