Second Generation 2015 Genesis - Apple Car Play not statying connected

bracki

Hasn't posted much yet...
4
0
0
First time post and was hoping someone could help out. Just got a Genesis 2015 and have successfully upgraded it to apple car play and android auto.

Problem is that with iPhone or sometime disconnects after 30 minutes sometimes after a few minutes. Doesn't seem to be rhyme or reason. Have done a lot to troubleshoot to no avail.

Things so far:
Made sure to use authentic apple USB cable
Have reinstalled the software
Have hard rebooted phone.
Have updated to latest software on phone and also tries installing apple beta software - iOS 10. Both cases the same problem happens.

Only thing I haven't done is wiped the phone and started fresh but would prefer not to do that.

I've also go an android phone and haven't noticed rbe same issues.

So my question for this group - has anyone else seen this? Is it something a dealer can help me with - seems unlikely? Any thoughts on what to do? One of the main reasons I purchased was because of car play so. Hammer it's not working....

Thanks for help!
 

patrick49

Registered Member
65
1
0
Austin, TX
Not sure what could be causing it, but I can say it doesn't matter if you're using an authentic Apple cable or not. My phone lives in a Mophie Juicepack, which is micro-USB and has always worked fine.

Is it a data connection issue with your phone? If you're on the home screen (the split Nav/Radio screen), does the green CarPlay icon disappear, or is it still there?

Very rarely it'll take a long time/fail to connect when I start the car up, but unplugging/replugging fixes it. Also rarely, sometimes my phone will drop it's data connection, but Car Play doesn't disconnect in that case.

Maybe try disconnecting the battery for ~15 minutes for a reset? Not sure if that'll actually do anything, but won't hurt.
 

bracki

Hasn't posted much yet...
4
0
0
When it happens which is frequently - the green logo goes away. I've down a factory reset on the phone and it happens as well. I also have an android phone and have the same thing happen with android auto. The whole software seems to crash.

I have reinstalled the software update and that didn't help. Haven't tried disconnecting battery to the unit. Will try.

Any other thoughts out there? Am I the only having this issue? Sounds like it.
______________________________
 

cuervoman

Hasn't posted much yet...
I had this problem with Android Auto. They only thing you might check is "USB Permissions" When I start android auto I have to tap a dropdown menu to change the phone from USB charging to USB data.
Not sure if Apple has that issue when plugging into a USB
 

Jeeman0

New member
2
0
1
Southern California (for now)
Genesis Model Type
2G Genesis Sedan (2015-2016)
I am having the exact same issue on a leased 2015 Genesis sedan that I purchased a few months ago. I upgraded the head unit to CarPlay and it worked great for a few weeks and now I get randomly disconnected. The other day, I plugged it in and it would not recognize my iPhone and would not even charge it. I swapped cables, tried my wife's iPhone, and still had the same issue. Didn't try to use it for a couple days and now I plugged it in and it is working again. Still disconnects randomly though. Did you find out what the problem was though the dealer?
______________________________
 

Mr. Incredible

SUSTAINING MEMBER
1,613
448
83
Genesis Model Type
Genesis G80 Sport
No CarPlay. But I recently had this issue with my iPad and charging it. It would start to charge then disconnect.

Was an authentic apple cable. But it turned out the cable was bad. At the lightning port it had broken on the inside.

I changed the cable and it started working again. So I carefully cut back the insulation on the bad cable until I saw where the internal wires has broken, which wasn’t visible with the insulation on.

Apple cables are cheap imo. Very thin and easily broken if they are bent or pulled too far, which is easy to do in a car
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top