BlueConnect BlueTooth Maximum devices paired

E43509

Hasn't posted much yet...
18
0
1
Just bought a 2009 Genesis and trying to pair my iphone. After entering setup, giving it a pin, pairing the phone which then shows connected, the Genesis BlueTooth says "Maximum devices paired". When I click the Genesis activation button again, it says pairing failed.
According to the http://www.jciblueconnect.com site, my iphone 4s ios6 (also tried an iphone 4 ios5) are compatible.
When I go into setup to list all devices or delete a device, the Genesis bluetooth says there are "No paired devices".
Ughh anyone have a solution?
Thanks
 

PMCErnie

Been here a long time....
3,586
146
63
Richmond, VA
Genesis Model Type
1G Genesis Sedan (2009-2014)
If you bought a used Genesis, it's likely that two cell phones were paired to it previously. Did you clear/delete those pairings before trying to pair your phone?
______________________________
 

E43509

Hasn't posted much yet...
18
0
1
Yep. It says that there are no paired devices when I list them or say to delete all.
Waiting on what the dealer will now say. I see some similar devices on eBay which may be my only recourse.
 

E43509

Hasn't posted much yet...
18
0
1
Bottom line:
It took weeks but dealer replaced the control unit under warranty. Not sure where they got the control unit but just sharing for others.

The longer story:
The dealer www.pohankahyundai.com didn't keep me informed informed that my BlueTooth was obsolete. It is a separate unit that is housed where you would normally have sunglass holder.

I was able to have the dealer give me my part number U8781-3MP00-BR.

I found some on ebay that were close (wrong color) and figured they could gut it for parts. One great seller on ebay provided a lot of info while he didn't have the part.
From ebay
Allen @ http://www.cioccahyundai.com/
In Hyundai Parts Number Speak the "BR" is the color. Having said that if you buy a bluetooth kit and the part numbers begin "U8781-3MP00" or "U8781-3M000" it will work with your car, the only difference is the color. The difference between the "P" and the "0" is P stands for Port installed option aka "PIO". Without the P it's a dealer installed option aka "DIO". The only difference between the two is the packaging. DIO's are packaged nicely to be shown at a dealership. PIO's are just in a plain bag/box with no frills for the installation technicians that work at the ports.

I had to continue to ping the dealer every few days in order to get the issue resolved.
 
Top