• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2009 Genesis" isn't going to indicate to anybody that you need help. However, "Need help with my 2009 Genesis Sedan" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Burger Motorsports JB4 high performance tuner now available for the Genesis 3.3TT

Slip_Angle

Registered Member
260
314
63
Winnipeg
Genesis Model Type
Genesis G70
^Those logs look great to me.

How'd you get ahold of 94 octane?
In the first screen shot I see ignition drop to 0 in 3 spots suddenly. In the second screen shot it happens once. In the third, there are no drops.

Correct me here if I'm reading it wrong but that looks like a response to something like knock vs. it being a normal part of the ignition map?

Never mind... gear changes.
 

EdsNotHere

Registered Member
122
89
28
Genesis Model Type
Genesis G70
I ordered these so I can run a cable through the firewall and have one plug on each end splicing to the ODB II wire to connector that way I can just disconnect it on the inside leaving one of these connectors and disconnect it on the outside along the wiring harness and wrap them with braided cable style sheathing and it looked just like Factory and nobody will ever know what it’s for so when I disconnect the JB4 they’ll be no telltale signs anywhere.
Also ordered some sheathing to put on the 02 sensor wires and the other wiring to make it all look factory.

2A17717A-9AA0-4A2E-85D7-1D36E90192E0.png
 

EdsNotHere

Registered Member
122
89
28
Genesis Model Type
Genesis G70
Had an odd issue today. Map 2 car is warmed up and sitting at a light engaged launch mode a stepped on the gas...nothing barely moved and check engine light on and into limp mode. Drove to a lot shut it off restarted no problems now. Not sure what would have triggered it since I just lightly touched the throttle and bam no power
 

NLJ

Registered Member
1,677
873
113
Genesis Model Type
Genesis G70
Had an odd issue today. Map 2 car is warmed up and sitting at a light engaged launch mode a stepped on the gas...nothing barely moved and check engine light on and into limp mode. Drove to a lot shut it off restarted no problems now. Not sure what would have triggered it since I just lightly touched the throttle and bam no power
Look at the Last Safety trigger. It is a read only and will give you a numerical value. 1 is Overboost Safety then there are a few more that will cause you to drop back to Map 0. However limp mode might be something more ECU related.
______________________________
 

EdsNotHere

Registered Member
122
89
28
Genesis Model Type
Genesis G70
Look at the Last Safety trigger. It is a read only and will give you a numerical value. 1 is Overboost Safety then there are a few more that will cause you to drop back to Map 0. However limp mode might be something more ECU related.

Last safety shows 0
It’s odd the check engine light was on but read it and no codes.

Plus it was running rough like a misfire. After shutdown/restart running perfect.
 
Last edited:

NLJ

Registered Member
1,677
873
113
Genesis Model Type
Genesis G70
Started to build and by 1000 rpm limp mode
Did you log it? Post it on the main sticky thread of N54Tech.
Don't start your own three there cause it rarely gets seen.
______________________________
 

EdsNotHere

Registered Member
122
89
28
Genesis Model Type
Genesis G70
Went out and tried to duplicate it and got nothing. Worked as expected.


Question for you guys. How much boost are you building on launch control before you go?
______________________________
 

Beefer

I’m faster
3,494
2,761
113
Richmond, VA
Genesis Model Type
Genesis G70
With Boostane should be about 94 octane.
I’ll keep an eye and maybe try to duplicate the issue
You running BOOSTane?

If so...make sure your tank has settled and everything is mixed probably. Also...ECU needs to adapt...so drive around nicely for at least 30 minutes...no cheating!
 

EdsNotHere

Registered Member
122
89
28
Genesis Model Type
Genesis G70
You running BOOSTane?

If so...make sure your tank has settled and everything is mixed probably. Also...ECU needs to adapt...so drive around nicely for at least 30 minutes...no cheating!
I did that days ago wen I filled up. Down to 1/4 tank now so should have mixed well the first day and drove normal for about an hour on map 2 after adding Boostane and filling up.
 
Top