• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2009 Genesis" isn't going to indicate to anybody that you need help. However, "Need help with my 2009 Genesis Sedan" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Tfish026

New member
2
0
1
Genesis Model Type
1G Genesis Coupe (2009-2016)
So let me explain what happened.
I decided to take out every single fuse and put it back in (no relay) in my GC 2.0T 2012. I did so and took it for a drive. When I got back I parked my car in gear, and left it to sit for a bit. I realized what I had done and went back to put it in Park. When I tried to start the car From park it would not start. It showed me the immobilizer icon so I tried neutral and it worked after pushing the button for 15 seconds. I have to put it in neutral and hold it for 15 seconds every time I start it now. Has anyone had this issue before? If so how do I fix my wrong mistake?
 

Tfish026

New member
2
0
1
Genesis Model Type
1G Genesis Coupe (2009-2016)
So let me explain what happened.
I decided to take out every single fuse and put it back in (no relay) in my GC 2.0T 2012. I did so and took it for a drive. When I got back I parked my car in gear, and left it to sit for a bit. I realized what I had done and went back to put it in Park. When I tried to start the car From park it would not start. It showed me the immobilizer icon so I tried neutral and it worked after pushing the button for 15 seconds. I have to put it in neutral and hold it for 15 seconds every time I start it now. Has anyone had this issue before? If so how do I fix my mistake?
 
Tired of waiting for a Genesis SUV?
Pedal Commander
hyundai palisade forums
Top