• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2009 Genesis" isn't going to indicate to anybody that you need help. However, "Need help with my 2009 Genesis Sedan" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

CarPlay annoyance!

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
Getting annoyed with my infotainment! My CarPlay works for a bit then stops. Seemed to be fine after I updated the phone and the firmware on my car but now it doesn’t connect at all! Any ideas? Am I the only one that this is happening to? Every time I go to the dealership their phones seem to work and I look like an idiot.

I’ve called Apple too and they ask me to do all the steps that I’ve done in the past. This has been an ongoing issue since I got the car!

I’ve tried different phones and cables. Other phones don’t even show the car in the CarPlay menu! Not sure what to do
 

tuckerdog1

Been here awhile...
315
79
28
TEXAS
Mine used to work fine, but suddenly started dropping off within a few seconds of connecting. Tried my wife's phone, and the same happened. Had an update for the phone I hadn't done, so did that. Still no luck. What finally worked is a compromise. If you turn bluetooth off on the phone, Car Play works.
______________________________
 

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
Mine used to work fine, but suddenly started dropping off within a few seconds of connecting. Tried my wife's phone, and the same happened. Had an update for the phone I hadn't done, so did that. Still no luck. What finally worked is a compromise. If you turn bluetooth off on the phone, Car Play works.
Mine used to work fine, but suddenly started dropping off within a few seconds of connecting. Tried my wife's phone, and the same happened. Had an update for the phone I hadn't done, so did that. Still no luck. What finally worked is a compromise. If you turn bluetooth off on the phone, Car Play works.
Thanks for the advice. I tried that and still not luck. Might have to call Apple again, which will probably lead to having to go to the dealer about this AGAIN 😕
 

joschneider

G70 Member
601
614
93
Las Vegas, NV
Genesis Model Type
Genesis G70
Ive got all sorts of other issues with carplay like:

- defaulting to my personal media (which is empty) instead of my last used app, like spotify
- crackly audio until I switch modes back and forth using the steering wheel mode button
- frozen/not playing audio until unplugging and plugging back in (timeline on song continues moving with no audio and then once unplugging it the timeline goes back to the original point and plays fine)

These all happen when first plugging my phone in but Ive never had it just stop working during a drive. FrankieD hope you get this figured out but if my experience is anything to go by....skip calling apple. They are no help
______________________________
 

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
Ive got all sorts of other issues with carplay like:

- defaulting to my personal media (which is empty) instead of my last used app, like spotify
- crackly audio until I switch modes back and forth using the steering wheel mode button
- frozen/not playing audio until unplugging and plugging back in (timeline on song continues moving with no audio and then once unplugging it the timeline goes back to the original point and plays fine)

These all happen when first plugging my phone in but Ive never had it just stop working during a drive. FrankieD hope you get this figured out but if my experience is anything to go by....skip calling apple. They are no help
At this point I would give anything to have your current problems given that it at least connects lol!
I think I will skip Apple and just contact the dealer. Hopefully they can do something about it.
 

johnny3fingers

Registered Member
37
8
8
Genesis Model Type
2G Genesis Sedan (2015-2016)
I dont but it. CP has been a POS for me. I have several IPones (ios12.x and 13.x) and they all disconnect randomly while driving and then refuse to reconnect. Ive tried different mifi approved cables, 4 diff cables.

Given all the other issues with these cars Im of the opinion its the infotainment center, proving it is the difficult part
 

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
I dont but it. CP has been a POS for me. I have several IPones (ios12.x and 13.x) and they all disconnect randomly while driving and then refuse to reconnect. Ive tried different mifi approved cables, 4 diff cables.

Given all the other issues with these cars Im of the opinion its the infotainment center, proving it is the difficult part
proving it definitely difficult. Especially when the phones they hook up always work when I take it in
______________________________
 

joschneider

G70 Member
601
614
93
Las Vegas, NV
Genesis Model Type
Genesis G70
proving it definitely difficult. Especially when the phones they hook up always work when I take it in
if their phones work, but the ones youve tried dont...have you checked for a difference in settings? There are certain ones like 'allow usb use when locked' ,'disable usb if not unlocked recently' (not the exact name of the setting), etc.
 

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
if their phones work, but the ones youve tried dont...have you checked for a difference in settings? There are certain ones like 'allow usb use when locked' ,'disable usb if not unlocked recently' (not the exact name of the setting), etc.
I have it enabled to connect to usb when locked. I dunno...it was working before and I didn’t change any settings so why it just stopped is beyond me 😔
 

joschneider

G70 Member
601
614
93
Las Vegas, NV
Genesis Model Type
Genesis G70
I have it enabled to connect to usb when locked. I dunno...it was working before and I didn’t change any settings so why it just stopped is beyond me 😔
updates are weird. maybe it didnt take all your settings or something. well if you get to the end of your rope and no one can fix it...theres a couple good suggestions to try in this article: How to Fix Apple CarPlay Not Connecting After iOS 13 Update

edit because the original link was broken. hopefuly the tinyurl works
 

FrankieD

Registered Member
114
62
28
Atlanta, GA, USA
Genesis Model Type
Genesis G70
updates are weird. maybe it didnt take all your settings or something. well if you get to the end of your rope and no one can fix it...theres a couple good suggestions to try in this article: How to Fix Apple CarPlay Not Connecting After iOS 13 Update

edit because the original link was broken. hopefuly the tinyurl works
Thanks! I appreciate the help. I will read over the article and try the fixes tomorrow. Hopefully something will work
______________________________
 
Tired of waiting for a Genesis SUV?
Pedal Commander
hyundai palisade forums
Top