Hyundai only one to reset air suspension?

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Hi all, new Equus owner and I’m pretty sure I have a leaking airbag.
I expected it, so not a big deal and negotiated it in the price.
I’ve seen the links/posts for the remanufactured bags or eBay ones. Question is: do I need to have it done by the dealer or can an independent shop do it?

Also, is there any way the system can get confused? Or a relay going bad? Sometimes it stay aired up overnight. Sometimes it’ll pump up when the car is started. There doesn’t seem to be a pattern of air leaking, it’s random.
Thanks all, been reading up just trying to confirm what I’ve read.
2013 Equus
 

cruno

Registered Member
55
15
8
NJ
Genesis Model Type
Equus (2011-2016)
I'm not sure if this is the case for the Equus, but our suspension systems are very similar to the W220 (Mercedes) air suspension system.

When I had an S500 I had to do an air suspension reset and to do that you had to hold the suspension raise button for like 10 or 30 seconds.

When I did that it would force all of the struts to raise to their maximum height (which it would not if you just pressed the button), and from there you could see which struts were either not able to retain air or were not getting air delivered to them.

Give that a shot and report back your findings.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
An update. Took the car back to the dealer where I bought it (non-Hyundai) and of course it was working perfectly today. BUT, the service manager saw the car yesterday when it was malfunctioning. They could not find a leak in the system, car was throwing no codes, and so they agreed that it appears to be the height sensors in the rear. (Front is not affected at all) Supposed to get an update in the morning as they had verbally agreed to take care of this as part of the sale. Parts appear to be $500, so not very expensive. We shall see.
______________________________
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
New wrinkle, car threw an ECS code this morning on my way to kids' school. Once I restarted car to leave, code was gone. So, now service is not convinced it's the sensors. As the car was not malfunctioning when it was in service, they want to give me a loaner sometime next week and try to duplicate the problem and see if it will throw the code again. So, I wait. Will keep updating this as there are more developments.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Car is officially going in on Monday. Feeling more and more like the passenger side rear air bag is the culprit.

I suggested installing the Strutmasters kit but the dealer wants to get codes and diagnose it first.

Will continue to update.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Talked to the tech, the air suspension has finally malfunctioned.
They ordered a part called a solenoid valve which will be there Saturday.
I expect the vehicle to be completed Monday.

Hopefully this does the trick. They gave me a VW Atlas as a loaner, it's alright but I want my Equus back :)
 

marklg

Registered Member
34
16
8
Charlotte NC
Genesis Model Type
Equus (2011-2016)
good to hear it is worked out.
______________________________
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
So, the part didn't get ordered in time for Saturday delivery. Supposed to get it back tomorrow.
 

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
Good luck with the car! Let us know if the solenoid valve does the trick. I just got my Equus a couple days ago and my Ride Height button doesn't always work. Sometimes it will raise and lower and other times I press it nothing happens. Hopefully, it's just something with the button and not a bigger issue.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Does your car stay at the correct height? The Ride Height button only works at 45mph and below. (I think that is the speed). Once you reach a certain speed it automatically returns to normal height. Depending on when you try to use it, that could be the problem.

Image 1 shows the system failing, Image 2 is when it's working correctly.

IMG_8229.jpg IMG_8226.jpg
 

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
Mine is staying at the normal height. But with the engine On and in Park the ride height button only works maybe 20% of the time. I’ve also tried pressing the button at a stop light and it almost never works. It just shows the down arrow and normal on the lcd screen. It doesn’t go to high mode. I saw an air suspension tube thing in the engine bay. Any idea what that does?
______________________________
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Mine is staying at the normal height. But with the engine On and in Park the ride height button only works maybe 20% of the time. I’ve also tried pressing the button at a stop light and it almost never works. It just shows the down arrow and normal on the lcd screen. It doesn’t go to high mode. I saw an air suspension tube thing in the engine bay. Any idea what that does?
I believe that’s the fill tube if the system gets low. Can’t confirm though. Did read you are supposed to have wheels off the ground when filling to avoid bursting the air bags.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Okay, update time. Car is done. Went to go pick it up. It's a cool (45 degrees)morning here and the suspension was riding in the correct position. YAY! I had hopes that it was fixed because it failed most often in cold weather. *spoiler alert, it was not fixed*

They gave me the report when I picked up the car. They had replaced the Air Suspension Solenoid Valve Block (PN# 55810-3M000) and I had a bill for $0.

Sweet! Unloaded the loaner, got the car seats re-installed in the Equus and headed home. About 15 minutes into my drive home I noticed the ECS light is now on. Ugh. Oh well, maybe it's gotta relearn with the new part. Nope. I immediately felt that the suspension had failed. Turned around and went back to the dealer. My loaner was still sitting in the service lane. They gave me back the keys and I unloaded the Equus again.

Will see what happens now. I give these guys credit, they have been 1000% awesome about this whole situation. The agreement to fix this was a verbal agreement at the time of sale. They could have easily backed out but they have continued to act in good faith.

West Houston Subaru/Volkswagen is a standup place! Will keep you updated when I hear more.
 

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
I believe that’s the fill tube if the system gets low. Can’t confirm though. Did read you are supposed to have wheels off the ground when filling to avoid bursting the air bags.
It’d be nice to have the ride height button working but it’s riding so nicely and not losing air pressure in any of the bags I might just let sleeping dogs lie. Thanks for all your input. I’ll be watching for updates.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Yeah I understand that completely. I didn't push the ride-height button when I picked up the car for that reason:) Turned out it didnt matter.
______________________________
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Spoke to the service department today. It hasn't failed since they've had the car (over a week), BUT it has been extremely nice weather. I think it's a leak somewhere because when they replaced the solenoid valve it didn't help one bit, it failed in the exact same way.

Anyway, they were going to give it back but I said today and tomorrow's cold weather (lows in the 30s/40s) would make it fail. So, they are going to keep it through the weekend and try getting it to fail.

Again, we'll see.
 

Laz523

Hasn't posted much yet...
2
0
1
Highland, IN
I have the same problem with my 2011. Took it to Hyundai dealer by my house and they said fuse was blown so they replaced that and filled air tank and didn't even get a block away and rear end had completely went down. Thinking of buy two new air bags, hopefully that fixes the problem. 20200214_030725.jpg
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
I have the same problem with my 2011. Took it to Hyundai dealer by my house and they said fuse was blown so they replaced that and filled air tank and didn't even get a block away and rear end had completely went down. Thinking of buy two new air bags, hopefully that fixes the problem. View attachment 27050

yeah. With mine exhibiting the same problem despite a new solenoid valve I’m guessing mine is also leaking airbags.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Finally got the car back because the dealer magically couldn't get the car to fail. I have the car 20 min. and the suspension fails. Ugh. No ECS light but the suspension is definitely not working correctly. Still nothing out of pocket and the dealer I purchased from is truly trying to figure it out, but it's getting frustrating.
 
The Genesis License Plate Frame
Tired of waiting for a Genesis SUV?
hyundai palisade forums
Top