• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2009 Genesis" isn't going to indicate to anybody that you need help. However, "Need help with my 2009 Genesis Sedan" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Mid-grade lexicon audio system - amplifier replacement (campaign t55)

jwaters943

Been here awhile...
1,319
6
0
Reno, NV
Re: Genesis Technical Service Bulletins

Thanks again for looking out for all of us Genesis owners! I already knew about the amplifier issue, but what's the deal on the ATF level? Are they coming with too much fluid from the factory? That sounds more serious.....uh oh, maybe I'll have to take mine in before the fist oil change.
 

BaywayRic

Been here awhile...
680
2
0
Re: Genesis Technical Service Bulletins

Thanks again for looking out for all of us Genesis owners! I already knew about the amplifier issue, but what's the deal on the ATF level? Are they coming with too much fluid from the factory? That sounds more serious.....uh oh, maybe I'll have to take mine in before the fist oil change.
The bulletin is an interesting read just to see the computerized diagnostic tools this beast has. Check out the data they can see real time. Because it is not a "campaign", I think this one is simply 'How to check the fluid level.' Probably got left out of some other tech pub.
 

Marth50

New member
2
0
1
I have a 2011 Genesis Sedan that the FM station go out and give nothing but loud static , the stations come in and out please help. by the way NO TINT . The radio has been replaced times.
______________________________
 

Brylor

New member
2
0
1
Genesis Model Type
1G Genesis Sedan (2009-2014)
I have a 2011 Genesis Sedan that the FM station go out and give nothing but loud static , the stations come in and out please help. by the way NO TINT . The radio has been replaced times.
I am having the same issue. I have a 2009 4.6 and the radio signal usually works great when the car is started but quickly fades to static soon after. This happens on any station and even on AM. The CD player still works and sounds fine and XM still plays well too. I am looking for help with this as it is really starting to bother me.
 

Rodney Dangerfield

Registered Member
20
6
3
Texas panhandle
Genesis Model Type
1G Genesis Sedan (2009-2014)
I am having the same issue. I have a 2009 4.6 and the radio signal usually works great when the car is started but quickly fades to static soon after. This happens on any station and even on AM. The CD player still works and sounds fine and XM still plays well too. I am looking for help with this as it is really starting to bother me.
You may need to reset the amplifier. This is an easier way to get into the engineering menu and if you have the first gen this will also tell you how to change it to the Prada screen. Just be careful what you mess with in this screen, you can seriously mess up things if you adjust something you didn't mean to.
 
Top