Radio stopped working and screen only displays logo.

coolpark202

Registered Member
15
6
3
Genesis Model Type
Equus (2011-2016)
I have a quick question that I hope someone has a good fix to.

I had just gotten some gas in my car and went to turn it on and the screen started freaking out. NAV screen displayed what looked like an windows error message and stopped working. I turned the car off and on, and the error message disappeared but the screen wouldn't go home anymore. The backup camera still works, the USB to plug in your phone does not work and is not charging my phone anymore.

The radio will turn on for a second but then turns off, and the system tries to reboot itself. I took it to the dealership but the technician I spoke with didn't seem to know what he was talking about. I asked him about it being a software error and if we could just reset/reinstall/update the software he said they don't really do that. I couldn't stick around because I had to get to a meeting. Has anyone ever dealt with this? equus.png
 

PMCErnie

Been here a long time....
4,267
488
83
Richmond, VA
Genesis Model Type
1G Genesis Sedan (2009-2014)
It’s possible it might be working again next time you start it up. Or, maybe the head unit is shot. Hopefully, you have an extended warranty.
 

EdP

Supporting Member
SUPPORTING MEMBER
SUSTAINING MEMBER
7,975
4,189
113
Parrish, FL
Genesis Model Type
Genesis G80
I have a quick question that I hope someone has a good fix to.

I had just gotten some gas in my car and went to turn it on and the screen started freaking out. NAV screen displayed what looked like an windows error message and stopped working. I turned the car off and on, and the error message disappeared but the screen wouldn't go home anymore. The backup camera still works, the USB to plug in your phone does not work and is not charging my phone anymore.

The radio will turn on for a second but then turns off, and the system tries to reboot itself. I took it to the dealership but the technician I spoke with didn't seem to know what he was talking about. I asked him about it being a software error and if we could just reset/reinstall/update the software he said they don't really do that. I couldn't stick around because I had to get to a meeting. Has anyone ever dealt with this? View attachment 24113
Some radios have a reset button. Look for a tiny hole on the front and push a ball point or paper clip in it to reset. If that does not work, sounds expensive.
 

knjames

Hasn't posted much yet...
3
0
1
Maryland
Genesis Model Type
Equus (2011-2016)
My radio does the thing. The dealer could never duplicate the problem. So it hasn't been fixed. I'm pretty sure we are not the only 2 equus owners with this issue. I do have a reset button that restores the radio.
______________________________
 

coolpark202

Registered Member
15
6
3
Genesis Model Type
Equus (2011-2016)
Update: Disconnected the battery and let sit for a half hour..... Now screen is all black. Except when I use the back-up camera.
 

Alfer

Registered Member
731
293
63
USA
Genesis Model Type
2G Genesis Sedan (2015-2016)
I take it this tip won't help (found here on this site from back in 2012..

We stopped at Hub Hyundai on Katy Freeway and caught George in Equus Service Department before he left for the evening and explained our problem. He opened the driver side door and removed the cover on the fuse box located on side of driver side dashboard and pulled the big YELLOW fuse and put it back into place and everything came back to life. He told me that it was a glich that Hyundai had discovered, but just removing and reinserting this fuse reboots the system??? Anyway I thought this might help a fellow Equus Owner if you run into this problem.
______________________________
 

knjames

Hasn't posted much yet...
3
0
1
Maryland
Genesis Model Type
Equus (2011-2016)
I take it this tip won't help (found here on this site from back in 2012..

We stopped at Hub Hyundai on Katy Freeway and caught George in Equus Service Department before he left for the evening and explained our problem. He opened the driver side door and removed the cover on the fuse box located on side of driver side dashboard and pulled the big YELLOW fuse and put it back into place and everything came back to life. He told me that it was a glich that Hyundai had discovered, but just removing and reinserting this fuse reboots the system??? Anyway I thought this might help a fellow Equus Owner if you run into this problem.
Yes doing that or pushing the reset button on your radio will reboot it then it will work. But that does not fix the problem. The issue will pop up again at some point in time. I believe Hyundai doesn't know how to fix this issue. I would think they would come up with a software fix and send it out to everyone.
 

EdP

Supporting Member
SUPPORTING MEMBER
SUSTAINING MEMBER
7,975
4,189
113
Parrish, FL
Genesis Model Type
Genesis G80
Yes doing that or pushing the reset button on your radio will reboot it then it will work. But that does not fix the problem. The issue will pop up again at some point in time. I believe Hyundai doesn't know how to fix this issue. I would think they would come up with a software fix and send it out to everyone.
If it is a intermittent hardware problem it may not be fixable with software.
 

coolpark202

Registered Member
15
6
3
Genesis Model Type
Equus (2011-2016)
UPDATE: I eventually found a used Head Unit (they are much cheaper on Ebay if you search "Radio" instead) for $188, plus around $130 to install I now have a working head unit and radio. I have to reset my Sirius and stuff but at least everything is functional. Total cost of around $330, I thought I was really going to bite the bullet on this one, but turned out not to be so bad.
 
The Genesis License Plate Frame
Tired of waiting for a Genesis SUV?
hyundai palisade forums
Top