Sirius Data offline. Unable to acquire signal.

Mr. Incredible

SUSTAINING MEMBER
1,614
448
83
Genesis Model Type
Genesis G80 Sport
For 3 days now my car has stated “no signal”. For sat data. No traffic, weather, etc will load.


I rely on the traffic for my commute and while I can use apple or google maps. I’m getting irritated with this issue.


Anyone else having an issue?
 
Last edited:

Mr. Incredible

SUSTAINING MEMBER
1,614
448
83
Genesis Model Type
Genesis G80 Sport
issue resolved. solution for anyone experiencing the same:

called the Sirius 800# on that unit that is displayed when you look at the subscription information.

press #2 for TECH SUPPORT, even if you do not have an active radio subscription.

make sure they connect you to TECH SUPPORT and not customer service, customer service will give you crap about not having an account and that's why it doesn't work, this is not true, your dealer setup your account for you give them the Sirius Device ID NOT YOUR PERSONAL INFORMATION, force them to access the account this way, then it comes up as ACTIVE DATA SERVICE ACCOUNT, not linked to an account holder.

too many times members here have gone through customer service and lost their free services because the rep sets them up a new account that wipes out the free account data.


Once you have a TECH on the line, explain that you have FREE DATA SERVICE through HYUNDAI, not through GENESIS, they don't recognize Genesis as a brand in their system.

they will do some trouble shooting and send a signal. This is the process that worked for mine:

  • Make sure that your phone is NOT connected via Bluetooth or Carplay, this interferes with update signal Sirius sends
  • reset the head unit with the reset button on the front above CD player
  • after reset reboots, Check status in the Sirius Data menu item, it should say subscription invalid
  • Turn off car (open door to kill power)
  • Sirius Sends Signal -- this is important the signal must be sent when the car is OFF, wait 5 minutes
  • Turn on car
  • wait for head unit to boot up
  • go back to menu and check status, it will still say invalid for approx. 3-5 minutes, then it will update to Subscribed to data services
  • Once the services are back you can plug in or Bluetooth connect your phone.
I felt the tech I had was very competent, she seems to know the procedure that would work in the exact steps needed, she didn't try a bunch of non-sense and fail at it, she was very specific in telling do exactly as I say when I say.

All my services came back and sync'd up.

She advised me that the last time my car contacted their system was last September when my free Radio expired, since I had no actual account with them when the car lost connection to their satellites. it could not resync as there was no actual account to sync with, once she plugged in my name and gave me an actual account number linked to my Radio ID number the unit was able to receive the signal.

At no time did she request any personal info other than my name just to have an account on file, not attempt to give me radio services or a subscription, this is important, because when you sign up for the radio service, if not done correct it wipes out the free data services.


I will never pay to use SiriusXM services, I don't care for their business practices, which is also why after 18 years of using Pandora One Radio (paid service) I have cancelled their service as they were recently purchased by SiriusXM and instead of $40 a year for unlimited Pandora, they automatically without my approval or permission switched me to a $14 a month auto charge service.
 
Last edited:

Mr. Incredible

SUSTAINING MEMBER
1,614
448
83
Genesis Model Type
Genesis G80 Sport
I'll add an update.

mine did work for a time after Sirius did their reset.. but it failed again..

what finally fixed it was going into the radio settings and choosing the option to reset the radio to default factory settings.

it wipes out all your settings, but this did fix it for me, it has been a month without issue.
 

Chad86tsi

Registered Member
34
14
8
Genesis Model Type
2G Genesis Sedan (2015-2016)
I'm in the 3 month free trial as it was reset by a dealer and I just got the car 1-1/2 weeks ago. Traffic worked the first day, then not at all for 3 or 4 days. I finally found advice from a google search that instructed me to tune to channel 1 (and another site said channel 2).

Every time I accessed the menu to verify traffic was checked "on", it said "can't connect". I had already verified subscription was valid. After I found the ch 1 advice, I went into the menu when it was still "not connected". I tuned to ch 1 and let it play that channel for a few minutes and looked again at the connection status, now it was connected and the map started to fill in with current data. That was 4 days ago, it's worked ever since. I think some of the back channel telemetry data is streamed in that channel. I'll update if it fails again and I have to do more troubleshooting. I mention this because I've heard others have the same issues I was having and they gave up.

Another factor that may have been corrupting my data integrity is that parked in my driveway I have very poor signal most of the time, even the audio cuts out. Where I park at work there is also a big tree I park under. It may not be getting good telemetry when in a sleep state.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top