TSB 12-BE-012 killed my NAV

Status
Not open for further replies.
Has anyone else had their NAV system "killed" when TSB 12-BE-012 was performed (DIS Operating S/W Update)?

Last week I had my Genny in the shop for a CEL (P0150 - O2 sensor failure).

Since it was going to be in for service anyways, I asked my service rep to do TSB 12-BE-012, which is the purported fix for issues like the audio system being muted at start-up, voice recognition failures, and surround sound going to OFF at start-up. I've had 3-4 instances of these issues since I bought my Genny in 2009, so I figured I'd get it taken care of now that they had a TSB on it.

When I got my car back, the NAV sytems was inoperative. When I checked the ENG page, the S/W listings for the Navi system and map database were blank, so it appears they were deleted when the TSB was performed. My Genny went back in the shop again and my service guy has not been able to get the NAV system to reload. He's checking with the HMA tech guys for recommendations. I'm just wondering if anyone else has experienced this and, if so, what their resolution was.
 

JDC

Been here awhile...
210
0
0
?

No one?

I've had a muted voice recognition on startups... and on those occasions it will last until the car interior seems to cool off pretty well - depending on how hot the interior is, 30 mins to 1 hour plus.

Have been waiting on a fix. I found if the car was in the sun and became very hot inside, my NDS errors would appear on startup. Leaving windows and sunroom a little ajar solved that.
 

bkleebauer

Getting familiar with the group...
Has anyone else had their NAV system "killed" when TSB 12-BE-012 was performed (DIS Operating S/W Update)?

Last week I had my Genny in the shop for a CEL (P0150 - O2 sensor failure).

Since it was going to be in for service anyways, I asked my service rep to do TSB 12-BE-012, which is the purported fix for issues like the audio system being muted at start-up, voice recognition failures, and surround sound going to OFF at start-up. I've had 3-4 instances of these issues since I bought my Genny in 2009, so I figured I'd get it taken care of now that they had a TSB on it.

When I got my car back, the NAV sytems was inoperative. When I checked the ENG page, the S/W listings for the Navi system and map database were blank, so it appears they were deleted when the TSB was performed. My Genny went back in the shop again and my service guy has not been able to get the NAV system to reload. He's checking with the HMA tech guys for recommendations. I'm just wondering if anyone else has experienced this and, if so, what their resolution was.
Where do you live at in Maryland? I'm in Carney just east of Towson. Did you ever get your problem fixed?
 
Where do you live at in Maryland? I'm in Carney just east of Towson. Did you ever get your problem fixed?
They haven't fixed my car yet and today makes it one month since the incident occurred.

I'm going to talk to my service rep again first thing tomorrow AM. He's been telling me for the past 2 weeks that he's "working with corporate" to find a fix. Personally I think I'm getting jerked around (albeit he's been very polite about it).

If he doesn't have positive news very soon about what they plan to do, I'll be sending a certified letter to the HMA President, the Hyundai Customer Connect Center at corporate HQ, the GM at the HMA Southern Region, and the local dealership owner documenting the whole issue and telling them that I would like my NAV fixed. (I'll be showing him a draft copy of that letter tomorrow AM)

Ironically, TSB 12-BE-012 has a big, fat warning that says "Don't turn off the NAV or cycle the ignition while the S/W update is being performed." Personally I think they screwed up the TSB and now they're trying to find a way to avoid the cost of a new Head Unit. They’ve tried re-installing the NAV system and it won't take. My Genny is past the 36-month warranty limit for the NAV, so I think they're trying to find a way to stick me with the bill.
______________________________
 

csnbharathi

Hasn't posted much yet...
the exact same thing happened to me yesterday at the dealership.

I took my car for my backup camera stopping right after rain or washing the vehicle, they took it in and contacted hyundai for a replacement camera. Hyundai asked the dealership to install the new TSB in question, they messed up the install i think and the nav stopped working.

I am still under warranty (15th of October), so they are ordering a head unit along with the backup camera, hope everything would be fine now.

Just an FYI! I purchased the extendedn platinum warranty from hyundai just to avoid costly repairs, paid about 1350 for 6 year and 85k coverage.

Good luck with your car.
 
If he doesn't have positive news very soon about what they plan to do, I'll be sending a certified letter to the HMA President, the Hyundai Customer Connect Center at corporate HQ, the GM at the HMA Southern Region, and the local dealership owner documenting the whole issue and telling them that I would like my NAV fixed.
The letters got sent on August 17th. Since then I've received a phone call from Abril [she wouldn't provide a last name even when I asked] at HMA Customer Connect, Ben Hall, HMA Southern Region Consumer Affairs Manager, and my local dealership's Parts/Service Manager. I had a half hour meeting with the local manager yesterday. He called me again today and said "Please bring in your car so that we can fix it." Everyone has been very professional and courteous so far [with the exception of refusing to provide a last name]. I'll be dropping my Genny off on Friday. Things seem to be progressing much better. I'll let you know how the repair goes.
 

csnbharathi

Hasn't posted much yet...
My NAV was updated to the 2010 version of the maps (Own a 2009 genesis).

The dealer is going to swap the head unit this friday, i assume they would give me the same or the latest version of the maps, not sure though.

My NAV is dead, so i cannot show them the version i have in there.
 

Holdercj

Registered Member
28
0
1
Omaha, NE
The letters got sent on August 17th. Since then I've received a phone call from Abril [she wouldn't provide a last name even when I asked] at HMA Customer Connect, Ben Hall, HMA Southern Region Consumer Affairs Manager, and my local dealership's Parts/Service Manager. I had a half hour meeting with the local manager yesterday. He called me again today and said "Please bring in your car so that we can fix it." Everyone has been very professional and courteous so far [with the exception of refusing to provide a last name]. I'll be dropping my Genny off on Friday. Things seem to be progressing much better. I'll let you know how the repair goes.
Mike, I took my '09 3.6 tech in for 09-BE-012 and they reported they fried my head unit. The rep said it was because the unit already had the update and they installed it anyways. Not sure how this could be as my software version version was 16.xxxx. The rep says everything works but the navigation. I'm not too happy of course then he says he is going to speak with his manager to see if they will fix it under warranty as if the cost would be my responsibility! You broke it ya dummy! I bet they didn't follow the TSB correctly like you mentioned.

Since you got great results with your letter I was wondering if I could get a copy and use it as a draft for my situation? Also how did you find out where to send it to? How can I find the Hyundai reps for my area?
______________________________
 

Holdercj

Registered Member
28
0
1
Omaha, NE
My NAV was updated to the 2010 version of the maps (Own a 2009 genesis).

The dealer is going to swap the head unit this friday, i assume they would give me the same or the latest version of the maps, not sure though.

My NAV is dead, so i cannot show them the version i have in there.
Did you get the most recent map update?
 

Holdercj

Registered Member
28
0
1
Omaha, NE
Well…The dealer came to their senses and replaced my head unit after they fried it. I picked up my car today and I have the updated DIS software and to my surprise updated maps. My XM traffic report now works as well. On a side note, does anybody know a good service center in Omaha? So far I am NOT impressed with Sid Dillon Hyundai.
 

waveman

Supporting Member
SUPPORTING MEMBER
SUSTAINING MEMBER
743
9
18
Alabama
Genesis Model Type
Genesis G90
Mike, I took my '09 3.6 tech in for 09-BE-012 and they reported they fried my head unit. The rep said it was because the unit already had the update and they installed it anyways. Not sure how this could be as my software version version was 16.xxxx. The rep says everything works but the navigation. I'm not too happy of course then he says he is going to speak with his manager to see if they will fix it under warranty as if the cost would be my responsibility! You broke it ya dummy! I bet they didn't follow the TSB correctly like you mentioned.

Since you got great results with your letter I was wondering if I could get a copy and use it as a draft for my situation? Also how did you find out where to send it to? How can I find the Hyundai reps for my area?
This is one of those situations where the cure is worse than the disease. I suspect that some service techs aren't properly trained on how to do firmware/software upgrades.
 

TimeOut

Registered Member
131
1
18
I had the TSB 12-BE-012-1 applied to my 2010 4.6 Tech last week. It took 1 and 1/2 hour to complete and everything went fine. We had the engine during the whole time and since it was the first software upgrade that this dealer performed on any car, they allowed me to sit in the passenger seat and watch the whole process. The first 40 minutes was for the UTA (amplifier) software update, after that it rebooted and started upgrading the Head Unit software plus other systems.
______________________________
 
Well…The dealer came to their senses and replaced my head unit after they fried it. I picked up my car today and I have the updated DIS software and to my surprise updated maps. My XM traffic report now works as well. On a side note, does anybody know a good service center in Omaha? So far I am NOT impressed with Sid Dillon Hyundai.
Chris - Glad to hear they took care of it, and please accept my apologies for not responding earlier. I've been "off the grid" for a while, so I did not see your request for help last month.

I left my Genny with my dealer while I was out of the country for 2 weeks last month. Everything was fixed when I returned and seems to be working fine (so far).

From the other replies I've seen here, I'm betting that they applied the TSB incorrectly the first time around. It was unfortunate that I had to play these games just to get my car fixed.
 

jaboyd

Getting familiar with the group...
38
0
0
I just had the TSB completed on my 2012 Rspec to correct the loss of surround sound settings when engine was restarted. Took the tech about 2 hrs to complete the install....all went well and no problems.

Thx guys for identifying this TSB for other members. When I went to the dealer they were first off not aware of a TSB for this issue, then they couldn't find the TSB so I gave them a print out of it. Low and behold they located the cds in their file and performed the work....all is well!

jeff
 

Darth Genesis

Hasn't posted much yet...
Hi all.

Sorry, this is really late in the game ... But, I'm in Montreal Canada (having recently acquired a 2010 4.6 sedan) and the local dealers look like deer caught in the headlights when I give them the TSB#.

Of course, it seems they have a completely different numbering scheme in Canada ... WTF?!

To Jeff (jaboyd): You say you handed them a printout of the TSB!!! Is there any way you might be able to scan and post this TSB so I could rub my dealers nose in it?? I've searched everywhere on the 'net and can't find this document ...

Thanks so much for any help!

Rod
 

OneFunGenesis

<- Runnin' on Empty
MODERATOR
2,178
4
0
Rochester, NY
please do not bump threads this old. The user you wanted the paper from has not been active in a long time. Please start a new thread if you still want this answer.

Thank you!

OFG
______________________________
 
Status
Not open for further replies.
Top