• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2009 Genesis" isn't going to indicate to anybody that you need help. However, "Need help with my 2009 Genesis Sedan" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

XM "channel unavailable" fooling everyone including XM. Help!

Turbosteve

Hasn't posted much yet...
10
0
0
Hi everyone. Look at the forum often but rarely post. However, I have a problem that nobody can seem to figure out regarding my XM.

Bought a 2010 genesis that came with the XM trial. Signed up and 3 months later, decided to keep it and paid for the year subscription. Ever since then, the XM has NOT worked, going on 4 months now.

The radio will not scroll past channel 1. When I try and move it to a preset channel (from when it was working during my free trial), the nav unit displays "channel unavailable"

Called XM about 20 times, no help. Refresh after refresh does nothing. Their "experts" have not helped and recommended that I bring the car to the dealership. I did that, and surprise surprise, no issues found.

Here is where it gets interesting: last week, XM had a free trial week and sure enough, my radio works and receives all of the satellite channels. As soon as the preview ends, so does all of my channels.

I called XM back once again and explained to them that it CAN NOT be a car or antenna issue if the radio was receiving all of the channels during the free preview week. The minute the preview ended, so did my access. So to me it must be some issue with XM thinking my radio does not have a valid subscription, even though they admit that I paid for the year this past February.

I am entirely frustrated and was wondering if anyone else has experienced this?
Any ideas?

Appreciate your help!
 

WowCool

Been here awhile...
418
0
0
Nr Jamestown CA
Have you checked All the relevant numbers on your radio with XM & Hyundai?
Maybe you have a replacement unregistered radio! (dealers are crafty beasts)
Did you get a Carfax?
 
Last edited:

Turbosteve

Hasn't posted much yet...
10
0
0
Yes, I turned the radio to channel 0 and read the radio ID.
That was my first thought, but I have supplied the radio ID directly from the nav unit on multiple occasions.

Is it possible that the radio ID displayed on the nav unit doesn't match the XM "brain" in the car? However, if that was the case, then my 90 day free trial would not have worked when I initially bought the car (??). I set that up using the same radio ID. No changes to the systems since.
______________________________
 

WowCool

Been here awhile...
418
0
0
Nr Jamestown CA
The Trial signal/receiver is Generic..
I suspect something in your unit has either been replaced, has become unserviceable or has been changed/replaced at some point in time....
If the vehicle is within the 3years Hyundai warranty - let a Hyundai dealer sort
the problem. If not, get them to diagnose & give you an estimate.....
Good Luck.........
 

Fast55

Been here awhile...
Be afraid, very afraid of XM/Sirius.

I am in my "trial" period on the new "G" and I have no intention of giving them any means of "auto billing" me again.

Google XM billing problems, and be warned.....................
 

WowCool

Been here awhile...
418
0
0
Nr Jamestown CA
Hi, I agree, BUT, you can request Paper Billing which means you can renew via a check to XM..;)
They did charge my AMEX card without authority! - I called and said "You have 24hours to return my money or I shout FRAUD..
Money refunded without delay............My Motto "Take No Crap..
 

Turbosteve

Hasn't posted much yet...
10
0
0
During the troubleshooting process with XM, they have asked me to power down the radio. I believe that they can "see" when the radio is turned off, which tells me that the radio ID matches the ID that they think it is. If the ID's were different, I would think that when I turned the radio off, XM would not recognize that I did that?

I have the original paperwork from the car (bought it as a certified used), so would any of the manuals, etc have the radio ID on it? It maybe interesting to see if the IDs match.
______________________________
 

WowCool

Been here awhile...
418
0
0
Nr Jamestown CA
I would call Hyundai Customer Service direct, get a Incident number and get them to check against their build info & the info you have....
If thats all OK, then it's a faulty radio unit.. Done & Dusted..
 

Mark_888

Registered Member
13,335
159
63
Genesis Model Type
1G Genesis Sedan (2009-2014)
During the troubleshooting process with XM, they have asked me to power down the radio. I believe that they can "see" when the radio is turned off, which tells me that the radio ID matches the ID that they think it is. If the ID's were different, I would think that when I turned the radio off, XM would not recognize that I did that?

I have the original paperwork from the car (bought it as a certified used), so would any of the manuals, etc have the radio ID on it? It maybe interesting to see if the IDs match.
I think the point is that a fair number of Tech Package audio/video head units have been replaced under warranty (as documented by Genesis Owners on this site), so the id's may not match. Most of the problems were minor or intermittent, but Hyundai could only replace the entire unit. A dealer or HMA should be able look up the warranty history of your car to determine if that happened.
 

landtuna

Registered Member
695
9
18
Sandstorm, AZ
During the troubleshooting process with XM, they have asked me to power down the radio. I believe that they can "see" when the radio is turned off...
XM/Sirius is not a two-way communication so the satellite cannot "see" that your radio is powered off or on. What they were doing is most probably resetting the radio to an initial status (perhaps it refreshes its ID when powered on or looks for its auth code).
 

Rudderman98

Registered Member
As of 6/6/13, XM is now sending intermittent singals. My system is signalling on and off. Called XM and they told me to set my system frequency for 100.3 on the FM dial.

No luck. To the dealer it goes.
______________________________
 

Rudderman98

Registered Member
Ok here's the skinny on anyone having XM reception issues in the last few weeks.

Apparently, solar flares are causing a disruption for those of us in the Pacific Northwest. I don't know if this is causing a problem for others in the U.S. My good buddy, along with my nephew who just purchased a new Jeep with XM is experiencing the same exact problems.

Both of them told me that the solar flares are the worst that anyone has seen in the last few years. So here's hoping I helped those with XM enabled in their vehicles on figuring out the source of the interruption since XM can't verify this problem.

http://www.nasa.gov/mission_pages/sunearth/news/News060813-m5.9flare.html
 

Rudderman98

Registered Member
Well an update from my last post.

Took the car to the dealer today because the XM signal loss was driving me nuts! I posted that solar flares could be causing the disruption of my XM connection. Well...

Tech told me that the connection to the antenna has loosened up causing the frequency loss. Great! Now the headliner has to come out for this fix.:mad:

Jeez what next? :rolleyes:
 

landtuna

Registered Member
695
9
18
Sandstorm, AZ
OMG!!! Solar Flare activity? And you bought that? Pssssst, hey buddy, shhhh, wanna by a bridge?
It isn't quite as far-fetched as you might think. When I had my BUD (Big Ugly Dish) for a number of years I would get lots of interference from solar flares and also when the sun was positioned right behind the satellite. The satts at that time were running about 25 watts per transponder and the sun's radiation would overwhelm the signal until it moved a few degrees. The new satts run about 100 watts per transponder and are less affected but they can still be affected by unusually strong radiation pulses.
______________________________
 

G-615111

Hi everyone. Look at the forum often but rarely post. However, I have a problem that nobody can seem to figure out regarding my XM.

Bought a 2010 genesis that came with the XM trial. Signed up and 3 months later, decided to keep it and paid for the year subscription. Ever since then, the XM has NOT worked, going on 4 months now.

The radio will not scroll past channel 1. When I try and move it to a preset channel (from when it was working during my free trial), the nav unit displays "channel unavailable"

Called XM about 20 times, no help. Refresh after refresh does nothing. Their "experts" have not helped and recommended that I bring the car to the dealership. I did that, and surprise surprise, no issues found.

Here is where it gets interesting: last week, XM had a free trial week and sure enough, my radio works and receives all of the satellite channels. As soon as the preview ends, so does all of my channels.

I called XM back once again and explained to them that it CAN NOT be a car or antenna issue if the radio was receiving all of the channels during the free preview week. The minute the preview ended, so did my access. So to me it must be some issue with XM thinking my radio does not have a valid subscription, even though they admit that I paid for the year this past February.

I am entirely frustrated and was wondering if anyone else has experienced this?
Any ideas?

Appreciate your help!
Yes. Same issue. No help from XM people..told me to wait 24 hours
 
Tired of waiting for a Genesis SUV?
Pedal Commander
hyundai palisade forums
Top