Hyundai only one to reset air suspension?

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
Finally got the car back because the dealer magically couldn't get the car to fail. I have the car 20 min. and the suspension fails. Ugh. No ECS light but the suspension is definitely not working correctly. Still nothing out of pocket and the dealer I purchased from is truly trying to figure it out, but it's getting frustrating.
Are there separate air compressors for the front and rear bags? I’m guessing they checked that already huh? My ECS light doesn’t come on unless I try to go into high mode then only my front goes up and ECS comes on. But if I turn off the car the front goes back to normal height and the ECS light goes away. I was thinking maybe I need the dealer to reset the suspension with the GDS but who knows. Does that dealer have the GDS?
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Are there separate air compressors for the front and rear bags? I’m guessing they checked that already huh? My ECS light doesn’t come on unless I try to go into high mode then only my front goes up and ECS comes on. But if I turn off the car the front goes back to normal height and the ECS light goes away. I was thinking maybe I need the dealer to reset the suspension with the GDS but who knows. Does that dealer have the GDS?
It was at a Hyundai dealer trying to get properly diagnosed (on their dime, I might add). I believe there is only one compressor for front and back.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
So, I've had the car back a week a few notes.
- Suspension has failed almost every day. Sometimes early in the day, sometimes after driving it all day.
- After sitting all night in the garage, the suspension has worked correctly every morning but eventually fails.
- I suspected that it was a leak in the airbags somewhere, so I felt that today's cold weather (was below freezing this morning) would exacerbate the problem. It didn't. The car has worked correctly all day. Going in and out of 'High Mode', hasn't lost air once. I no longer think it's a leak, but something 'electrical'.

I'm actually starting to wonder if a dying battery might be the culprit of my gremlins. The car sat on the dealer lot for a quite while. Since I purchased it, it's basically been in the shop for 3 weeks while they try to diagnose the problem. So, it's just been sitting and draining power without much drive time to recharge. Looked at the carfax records and the battery/charging system was checked. No record of it being replaced (and the car has decent records). I looked at the battery but I couldn't find a date on it, but it looks like the original battery still. If so, it's WAY past being needed to be replaced.

Might not solve my problems, but needs to be done anyway. Thanks for reading my novel. Will keep you updated, as usual:)
 

princelybug

SUSTAINING MEMBER
266
85
28
SoCal
Genesis Model Type
Equus (2011-2016)
Sorry to hear the update...What a headache! Yes, a 7 y/o battery is probably due for replacement. I'd take it back to the dealer as soon as possible.
______________________________
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Update time. Replaced the battery yesterday with a new AGM one from Advance Auto Parts. The battery was definitely degraded and having issues. It still had enough cranking amps (just barely) but was registering as needing to be charged. Worth the peace of mind to replace it and I immediately noticed an improvement at startup. Going on two days of no failures. *knocks on wood*

FYI, when it first started failing my initial thought was a sensor failing because how/when it failed, it made it seem like the system was 'confused'. Recent minor electrical anomalies pushed me to look at the battery. It's still early, but initial returns are encouraging!

(TANGENT ALERT) If you ever need parts, sign up for AAP's FREE online program. You can order their parts online and they'll have them waiting for you when you arrive. I constantly get email coupons from them and scored this bad boy for 25% off. I have no affiliation with the company, just been impressed with their products and their coupons :)
Advance Auto Parts - Down for Maintenance
 

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
Update time. Replaced the battery yesterday with a new AGM one from Advance Auto Parts. The battery was definitely degraded and having issues. It still had enough cranking amps (just barely) but was registering as needing to be charged. Worth the peace of mind to replace it and I immediately noticed an improvement at startup. Going on two days of no failures. *knocks on wood*

FYI, when it first started failing my initial thought was a sensor failing because how/when it failed, it made it seem like the system was 'confused'. Recent minor electrical anomalies pushed me to look at the battery. It's still early, but initial returns are encouraging!

(TANGENT ALERT) If you ever need parts, sign up for AAP's FREE online program. You can order their parts online and they'll have them waiting for you when you arrive. I constantly get email coupons from them and scored this bad boy for 25% off. I have no affiliation with the company, just been impressed with their products and their coupons :)
Advance Auto Parts - Down for Maintenance
That's sounds promising! Keeping my fingers crossed for you!
 

kiwon

Registered Member
28
11
3
Genesis Model Type
Equus (2011-2016)
That's sounds promising! Keeping my fingers crossed for you!
I just fixed my air suspension issues by replacing the 15amp fuse in the drivers side panel marked ECS!! Fuse wasn’t blown but the pins were discolored brownish black. Now the front and back air bags are going up and down on command and no ECS warning light. Woooohoo!!
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
I will have to check that out. After two days of no failures, about 90 min into a 2 hr drive it failed on me, complete with ECS light. Ugh.

However, if I turn off the car everything resets and it'll raise back up. Sometimes for 30 minutes, sometimes longer. I'm pretty confident it's not a leak. I'm going to go check the fuse in a bit.

Don't feel bad about replacing the battery but it was clearly acting up.
______________________________
 

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
I have 2014 Equus, same problem, no air leak car stays on same level like in normal mode. I go to Hyundai dealer and they told me to replace solenoid for $1350. I did it with my mechanic. Check everything no air leaking but error stil appears after some time of driving.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
I have 2014 Equus, same problem, no air leak car stays on same level like in normal mode. I go to Hyundai dealer and they told me to replace solenoid for $1350. I did it with my mechanic. Check everything no air leaking but error stil appears after some time of driving.
I take it back in tomorrow. I think it’s the Suspension ECU. Due to the virus, it sat for 4 days and never lost air pressure. Drive it today and passenger rear failed after a 5 minutes drive to the store. Finish shopping, drive home and it was working normally. Ugh.
 

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
Waiting for result. I think problem is electrical because it doesn’t have any pattern in error message and no air leak. I hope it’s work for us
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Waiting for result. I think problem is electrical because it doesn’t have any pattern in error message and no air leak. I hope it’s work for us

I don’t think it’s the main ECU because I’m not having intermittent issues with any other component.

Keep me updated if you figure something out. I’ll do the same.
______________________________
 

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
Update. Today car suddenly drop down front while I was driving. Change solenoid didn’t work, now ECS light comes up every time after 5 minutes I start car. After I stop for 10 minutes and start car again it pump front to normal position. Ugh
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
Update. Today car suddenly drop down front while I was driving. Change solenoid didn’t work, now ECS light comes up every time after 5 minutes I start car. After I stop for 10 minutes and start car again it pump front to normal position. Ugh
Oof. Mine hasn’t done that yet. It IS at the dealer now though. Still convinced our problem is suspension ecu. If it was a simple air leak it wouldn’t think it would reinflate after a reset. Also would think compressor is fine if it can reinflate it. ECU is not only the logical choice but about the only thing left to try.
 

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
Pretty close problem I use to have on Lexus LS and that was height sensor. If that doesn’t work out I probably do conversation to regular struts
 
Last edited:

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
Update. Connect to OBD scanner and you can see on picture fault codes. 0A34C896-BD82-4644-976A-8BEBC2636182.jpeg
Can someone tell me if do I need to calibrate sensors after solenoid change?
______________________________
 

Komari4

New member
9
2
3
Genesis Model Type
Equus (2011-2016)
I suppose that was bad solenoid that we installed. Order new OEM. C1709 error probably because of car start when it were on lift.
 

CubSmurf

Hasn't posted much yet...
62
20
8
TX
Genesis Model Type
Equus (2011-2016)
When do you expect the solenoid to be installed? I'm curious if that will fix it.

I talked to the dealer today, even with the suspension failing it's not throwing codes and they are offering to buy it back from me.

I'm torn because I absolutely adore the car other than the troublesome suspension. Especially in light of today's world, doesn't seem worth dealing with this issues...
 
The Genesis License Plate Frame
Tired of waiting for a Genesis SUV?
hyundai palisade forums
Top